Support

Emulator Response or Synchronization Error

4/18/07

Applies to:  Foxtrot LE

 

Summary

When running or stepping through a script, Foxtrot returns the error message ’Unexpected Emulator Response or Synchronization Error’, with a ’Response Code of 5’.

 

Cause

This message is typically displayed when Foxtrot runs too fast for the host system and gets ahead of the screens.  When that happens, certain control keys (Position Cursor, Enter Text or Number) are executed on a "locked" portion of the screen, resulting in an error.

 

 

Resolution

There are a two confirmations that need to take place first:

 

1.   Confirm that all Position Cursors, Enter Text or Number and all Database fields used in the script are being sent to valid positions on the host screen.  (If fields have moved or screens have changed, you will need to adjust your script).

 

2.   After any Enter, Page Up or Page Down or Function Key that changes the screen on the host system, there should be Check Screen or Script Search Control Key to ensure that the host has gone to the correct screen.  If you are working with a Unisys host system, see "Poor Performance or Errors working with a Unisys host"

 

Once this has been confirmed, the following steps should resolve problem:

 

1.   Activate Retry Check Screen & Retry Script Search. In ’Tools/Options/Preferences/Scripting’ this option should be selected.  First try the ’Check for Redraw Only’ option.  This will allow the host screen to "refresh" before the retry executes.  If this does not solve the option, uncheck the ’Check for Redraw Only’ and try again.

 

2.   If that doesn’t resolve the problem, check ’Check for Redraw’ again and increase the interval between comparisons.

 

3.   If you still experience errors, uncheck ’Check for Redraw Only’ and try again, leaving the increased time between comparisons.

 

4. In the Prefrences menu click the Timing and Running option and check the Clear 'Input Inhibit' on Errors option. 

 

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You will have to determine optimal settings for the "Try up to..." and the "Try every..." on your system through trial and error.

 

If after exhausting these methods have still not resolved the issue, please contact EnableSoft at Support@Enablesoft.com or 1 (800) 658-1147.

 

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